Param Target - ParamTarget.js

シェア用テキスト:
▼Param Target(ぽんぽこねるそん様作)
https://plugin.fungamemake.com/archives/23779
戦闘中のスキル・アイテム使用時に敵グループか味方パーティの中で特定の能力値が1番高いキャラをターゲットにします。

ふりがな:ぱらむたーげっと

機能概要: 戦闘中のスキル・アイテム使用時に敵グループか味方パーティの中で特定の能力値が1番高いキャラをターゲットにします。

利用規約(ライセンス): MITライセンス

作者:ぽんぽこねるそん

直接ダウンロード:Zipファイル

ダウンロードページ:https://detail.chiebukuro.yahoo.co.jp/qa/question_detai…

ファイル名:ParamTarget.js

プラグインのヘルプ:

/*:
 * @plugindesc 戦闘中のスキル・アイテム使用時に敵グループか味方パーティの中で特定の能力値が1番高いキャラをターゲットにします。
 * @author ぽんぽこねるそん
 *
 * @help
 * 使い方
 * ・スキル・アイテムのメモ欄に
 *     <能力値ターゲット:能力値ID> と記述すると
 *     対象の中で能力値IDの能力値が1番高いキャラをターゲットにします。
 *     能力値が同じ場合はインデックスが若いほうが選択されます。
 *
 * ・対象
 *     敵単体~敵4体ランダム ……使用者の敵グループ
 *                              「アクター:敵グループ・エネミー:味方パーティ」
 *     味方単体・全体………………使用者の味方グループ
 *                              「アクター:味方パーティ・エネミー:敵グループ」
 *     それ以外は効果がありません。(通常のターゲットを選択します)
 *
 * ・能力値ID
 *     0……最大HP
 *     1……最大MP
 *     2……攻撃力
 *     3……防御力
 *     4……魔法力
 *     5……魔法防御
 *     6……敏捷性
 *     7……運
 *
 * ・記述例
 *     最大HPが1番高いキャラをターゲットにする場合
 *     <能力値ターゲット:0>   と記述する
 *
 *
 *
 * このプラグインにはプラグインコマンドはありません。
 *
 * このプラグインはTriacontane様のScopeExtendから一部を使わせていただきました。
 *
 */
0

スポンサードリンク

スポンサードリンク

Copyright© #ツクプラ , 2020 All Rights Reserved.